MetaProduct User Forums

Offline Explorer virtual box

Offline Explorer

more details   development history   free download   buy now  

Missing section

Author Message
Andres 3/9/2016 6:57:54 PM
Hi

I am trying to download the homepage from percentil.com and everything is ok except one section is missing, the image slider located at the botton, under the title "RECIEN HORNEADO".

Could you please help me? I have tried various parameter combinations without any success.

Many thanks for your help.
Best regards

Andres
Oleg Chernavin 3/9/2016 7:46:13 PM
I would suggest you to select the Project that partially downloaded the site and then click the Browse With AutoSave button on the Home tab of the Ribbon. Offline Explorer should download missing files.

Best regards,
Oleg Chernavin
MP Staff
Andres 3/12/2016 6:02:02 AM
Hello Oleg

Thanks for your suggestion, now all the files are downloaded.

The problem now is that the page works ok with the built-in Offline Pro web server, but, when I upload it to my own web server in Internet, I receive some browser alerts showing Javascript-related errors, once I dismiss the errors, the page loads ok except for the said image carousel.

Any ideas why the page works ok with the built-in server and not online with my own server?


Many thanks for your help.
Best regards
Oleg Chernavin 3/12/2016 2:41:01 PM
Perhaps, not all scripts were placed to the web server. Some of them may reside on other servers and were placed to different directories on your hard disk.

You may give me a link to the republished web version (if this webserver is public) and I will see what is absent there.

Oleg.
Andres 3/15/2016 5:53:45 PM
Hi Oleg

Thanks for your answer. The republished web version is located at

http://e-lexica.com/percentil/percentil.com/

while the original URL is

percentil.com

The Spanish error messages, for example,

"No existe el objeto EventManager en Siviglia.Dom.EventManager"

translates into

"Object EventManager does not exist in Siviglia.Dom.EventManager"

Thanks again for your help.
Best regards

Andres
Oleg Chernavin 3/15/2016 7:22:58 PM
I could suggest a quick way to overcome this. Select this Project, click the Find Contents button on toolbar.

Enter the search phrase:

"no existe el objeto"

With quote symbols. Then uncheck all boxes and check only one - Search inside HTML tags. Click the Find button.

You will have a list of 1 or more files like siviglia.js@nc=1458082555

Select first of them and click Edit. The Internal Editor will show a line like:

alert("No existe el objeto "+objName+" en "+name);

Disable this line by typing // in front of it. So, the script code looks like:

if(!context[objName])
{
// alert("No existe el objeto "+objName+" en "+name);
}


Click the Save button on the Editor toolbar. If there are several files found, select another, click Edit and repeat the above.

Then republish the site again.

Oleg.
Andres 3/17/2016 7:21:24 AM
Hi Oleg

Thanks for the suggestion, I will try it and let you know the result.

Best regards

Andres

Andres 5/10/2016 3:14:12 PM
Hi again

The workaround worked for the alert messages, but the "RECIEN HORNEADO" still is missing in the republished online site.

But the website works ok, including the missing section, when browsed from the internal Offline Explorer web server (ie, I can see ok from the program itself and while accessing to 127.0.0.1:800 host).

So, my question now is, what web server Offline Explorer uses? Would it be possible to setup the same web server on Internet so it behaves the same as the local, internal one?

Many thanks for your support

Andres

Oleg Chernavin 5/10/2016 4:47:43 PM
It uses its own web server code. You may export (Export Files button) it to an EXE file, which will include the web server and run that resulting EXE file. Would this work?

Oleg.
Andres 5/10/2016 5:22:41 PM
Hi

Not unfortunately, the goal is to show a modified homepage version to the client and would prefer not to send them an exe.

I have setup a different, local web server in my computer and it shows the same issues... maybe OE modifies any paths or anything else? ie, any clues on why using the OE internal server works ok while a local or Internet web server doesn't?

Thanks and best regards
Andres
Oleg Chernavin 5/10/2016 6:48:05 PM
It is because there are 2 files exported:

filter@action=init

index.php@output=json&o=product&ds=getfeaturedproducts&&output=json

The webpage requests for a URL like:

http://percentil.com/index.php?output=json&o=product&ds=getfeaturedproducts&&output=json

The Apache web server tries to find and execute the index.php file, which is missing. Offline Explorer server takes the above file, replaces ? with @ and outputs the file. The page scripts work correctly in this case, no error message occur and the page section gets displayed.

I really don't know how to make Apache web server to treat this file differently.

Oleg.
Andres 5/11/2016 5:40:33 AM
I see, many thanks for the info.

Best regards

Andres
Oleg Chernavin 5/11/2016 5:41:26 PM
You are welcome! Sorry for being unable to help with this.

Oleg.